Orange Forum • View topic - orange MDS does not work on fedora

orange MDS does not work on fedora

Report bugs (or imagined bugs).
(Archived/read-only, please use our ticketing system for reporting bugs and their discussion.)
Forum rules
Archived/read-only, please use our ticketing system for reporting bugs and their discussion.

orange MDS does not work on fedora

Postby prout » Tue Nov 09, 2010 13:28


just to let you know the Multidimensional scaling tool does not work on fedora.

I am running fedora 10 and python 2.5

I installed from the source (8 Nov 2010). Everything seemed Ok, until I launched the example code given there

First, I had the weird error when importing ornfMDS:
Code: Select all
import orangeom as orangemds
ImportError: cannot open shared object file: No such file or directory

which is surprsing since import orange works.
So I observed changing the LD_LIBRARY_PATH to include the file where was solved the problem (I do not know why).

Second, I had this error when trying to run the example file
Code: Select all
  File "", line 18, in <module>
  File "/usr/lib64/python2.5/site-packages/orange/", line 92, in __init__
    self.mds=orangemds.MDS(distances, dim, **kwargs)
TypeError: argument 1 must be (unspecified), not orange.SymMatrix

Seems bad.
Hope somebody can fix this.
I am going to look for another MDS with python.


Postby Ales » Tue Nov 09, 2010 22:08

Which building instructions did you follow. Because the instructions for building seem to be missing one final command (but it is included in the Suse instructions here

This is probably what caused your problems.
Try running:
Code: Select all
sudo ln -s /usr/lib64/python2.5/site-packages/orange/ /usr/lib64/

and then see if script works.

Postby Ales » Wed Nov 10, 2010 14:19

Disregard my previous post.
The installation instructions are correct. Which leads me to believe you installed orange through script (which is really the one that was in error i.e. it reqired root access to install a sym link to a hard coded path "/usr/lib"). I have changed it to use RPATH linker argument to find the proper shared library. This makes it posible to install complete orange into the users local site-packages.

Postby prout » Wed Nov 10, 2010 15:51

Thank you very much!

Do you have any hint for the second problem?


Postby prout » Wed Nov 10, 2010 16:55

I installed orange again: it still create a link in /usr/lib/ and not in /usr/lib64/
which is necessary for me since I am running a 64bit proc.

I fixed it by creating a link in /usr/lib64 as you suggested.

I am still blocked at the second step.

Thank you anyway!

Return to Bugs