Orange Forum • View topic - Icons not showing up in Linux

Icons not showing up in Linux

Report bugs (or imagined bugs).
(Archived/read-only, please use our ticketing system for reporting bugs and their discussion.)
Forum rules
Archived/read-only, please use our ticketing system for reporting bugs and their discussion.

Icons not showing up in Linux

Postby Guest » Sat Jan 15, 2005 19:08

I've installed Orange on MEPIS linux ( a debian variant).
But the toolbar icons are not showing up. netither are any of the icons that are put on the canvas.
what could be the problem?

thanks in advance. :D
Pradeep

Postby Gregor Leban » Fri Jan 21, 2005 22:28

Hi,

it's very difficult to guess from your description what could be the reason.

Check if your Orange\OrangeWidgets\icons folder contains icons with png extension (there should be about 75 icons). If that is not the problem than it is most likely to be a qt issue on your linux version - maybe QPixmap needs some extra parameter or something like that (we have already had such problems with some other qt classes when we were porting to Mac).

Since we don't have you linux distribution (we only test on redhat, where it works fine), I can't give you any other tips. Sorry.

Gregor

Postby Guest » Tue Feb 15, 2005 10:22

The problem is probably caused by the fact that "make install" does
not work. The icons are not copied to wherever you are installing orange,
you have to copy them manually.

Also, don't forget the ones under OrangeWidgets/icons


Return to Bugs