Orange Forum • View topic - Canvas on Python 2.5 seems to be asking for a Python 2.3 DLL

Canvas on Python 2.5 seems to be asking for a Python 2.3 DLL

Report bugs (or imagined bugs).
(Archived/read-only, please use our ticketing system for reporting bugs and their discussion.)
Forum rules
Archived/read-only, please use our ticketing system for reporting bugs and their discussion.

Canvas on Python 2.5 seems to be asking for a Python 2.3 DLL

Postby herdrick » Thu Mar 15, 2007 22:42

Last edited by herdrick on Tue Jul 13, 2010 20:48, edited 1 time in total.

Postby Janez » Tue Mar 20, 2007 18:07

Hi,

you can have multiple versions of Python installed. I have 2.3, 2.4 and 2.5 and can run Orange with any of them.

As far as I can tell, we are distributing the right version of _orngCRS.pyd, that is, the one linked with python25.dll. Are you sure that you don't have any stray _orngCRS.pyd files lying around?

Anyway, you can download the file for Python 2.5 from http://www.ailab.si/orange/download/bin ... rngCRS.pyd.


As for the update in the canvas: yes, the problem is that orange.pyd is already imported, so it cannot be replaced. We'll see what we can do.

Janez


Return to Bugs



cron