Orange Forum • View topic - Linux and Widgets

Linux and Widgets

Report bugs (or imagined bugs).
(Archived/read-only, please use our ticketing system for reporting bugs and their discussion.)
Forum rules
Archived/read-only, please use our ticketing system for reporting bugs and their discussion.

Linux and Widgets

Postby skrat » Mon Apr 11, 2005 23:31

I am trying to install and run orange under Linux. When I am trying to open data file in canvas I get the following error:

Code: Select all
Unhandled exception of type exceptions.RuntimeError  occured at 0:22:12:
Traceback:
  File: orngDoc.py in line 238
  Function name: addWidget
  Code: newwidget = orngCanvasItems.CanvasWidget(self.signalManager, self.canvas, self.canvasView, widget, self.canvasDlg.defaultPic, self.canvasDlg)
    File: orngCanvasItems.py in line 271
    Function name: __init__
    Code: exec(code)
      File: OWFile.py in line 15
      Function name: ?
      Code: import OWGUI, string, os.path
        File: OWGUI.py in line 10
        Function name: ?
        Code: import qwt
          File: __init__.py in line 38
          Function name: ?
          Code: from _qwt import *
          Exception type: exceptions.RuntimeError
          Exception value: the sip module supports API v1.0 to v1.0 but the _qwt module requires API v0.1


This requirement looks kind of odd to me :/ Any ideas?

Btw. It would be very nice to provide some kind of requirements list to compile and run Orange under Linux. Unfortunately I don't have any Windows machine to try running Orange there (while I have several Linux computers) and It gives me really hard time to figure out all dependencies and get it compiled and run together with widgets under Linux. I would really like to provide that list but unfortunately after all the trying I am not sure anymore, what was really the necessary python package to get it "work" and what is only bloat on my computer.

Postby jurem » Thu Apr 14, 2005 4:24

Hi,
sorry for late reply. I cannot reproduce your exception, so I would like you to give me more information about you system(s). Which distribution(s) are you using?

It would be really nice, if you could run a script like..:
<...cut...>
import sys,sipconfig,pyqtconfig

print "Python version: "+sys.version
print "PyQT version: "+pyqtconfig.Configuration().pyqt_version_str
print "SIP version: "+sipconfig.Configuration().sip_version_str
<...cut...>
... and post output here. I am suspecting problems with SIP module.
There will be build & installation script ready soon (using Pythons Distutils) and I will describe requirements on the web then.

Rough requirements list would be:
- Python 2.3 (for now)
- Numeric Python (http://numeric.scipy.org/)
-* SIP Config (http://www.river-bank.demon.co.uk/download/sip/) - needed by PyQT
-* PyQT (http://www.river-bank.demon.co.uk/download/PyQt/)

(* - needed only if OrangeCanvas & OrangeWidgets will be used)

Regards, Jure

Postby tomaz » Thu Oct 27, 2005 12:09

For Linux installation please see download page.


Return to Bugs