Orange Forum • View topic - Installing on OS X 10.6 (Snow Leopard)

Installing on OS X 10.6 (Snow Leopard)

Report bugs (or imagined bugs).
(Archived/read-only, please use our ticketing system for reporting bugs and their discussion.)
Forum rules
Archived/read-only, please use our ticketing system for reporting bugs and their discussion.

Installing on OS X 10.6 (Snow Leopard)

Postby wbknox » Wed Nov 04, 2009 3:16

Hi,

I'm running OS X 10.6. I've followed the directions for installing Orange via Fink on Mas OS X (at http://www.ailab.si/orange/nightly_builds.html). I have installed Fink, XCode, and already had x11 installed (version 2.3.4).

When I run the given install script (at http://www.ailab.si/svn/orange/trunk/in ... -orange.sh), I get errors and incorrect warnings. I'll paste the output at the bottom. Any advice would be much appreciated.

Thanks!


Output:

Preparing local ailab Fink info files repository.
Updating local ailab Fink info files repository.
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
100 4612 100 4612 0 0 8930 0 --:--:-- --:--:-- --:--:-- 13446
Updating the list of locally available binary packages.
Scanning dists/local/main/binary-darwin-i386
Scanning dists/stable/main/binary-darwin-i386
Scanning dists/stable/crypto/binary-darwin-i386
Scanning dists/ailab/main/binary-darwin-i386
Scanning package description files..........
-EOMSG

Information about ailab packages have been updated. You can now update installed
packages using:

fink update-all

You can list available ailab packages using commands like:

fink list --tab orange

and you can install them using commands like:

fink install orange
EOMSG

if ! grep '^Trees:' /sw/etc/fink.conf | grep -q 'unstable/main' && grep '^SelfUpdateMethod:' /sw/etc/fink.conf | grep -q 'point'; then
cat <<EOF
-EOMSG

WARNING: Your local Fink installation does not seem to use unstable Fink
packages tree with rsync or CVS updating. This means that it could
happen that some package on which ailab packages depend will not be
found or possible to install. In this case please configure Fink to
use unstable tree using:

fink configure

and after that upgrade Fink to rsync updating using:

fink scanpackages
fink selfupdate
fink selfupdate-rsync
fink update-all
EOMSG

if [ ! -x /usr/bin/xcodebuild ]; then
cat <<EOF
-EOMSG

You will need Xcode installed on a system for above commands to work
correctly as it is a requirement for unstable Fink packages tree. You
can install it from your Mac OS X installation disk or from:

http://developer.apple.com/technology/xcode.html
EOMSG
fi
fi

if [ 6 -lt "5" ] && [ ! -x /usr/X11/bin/X ]; then
cat <<EOF
-EOMSG

WARNING: It seems you do not have X11 installed on a system. This means that it
could happen that some package on which ailab packages depend will fail
to run or compile. In this case please install it from your Mac OS X
installation disk.
EOMSG
elif [ 6 -ge "5" ] && [ ! "4" -gt "3" ]; then
cat <<EOF
-EOMSG

WARNING: It seems you do not have X11 version 2.3.0 or later installed on a
system. This means that it could happen that some package on which
ailab packages depend will fail to run or compile. In this case
please install a newer version from:

http://xquartz.macosforge.org/trac/wiki
EOMSG
fi

./fink-selfupdate-orange.sh: line 119: EOF: command not found
Script failed

Postby wbknox » Wed Nov 04, 2009 3:38

I should add that I do have the unstable packages tree in fink enabled.

Postby Blaz » Mon Nov 16, 2009 9:14

I got a similar installation problem with fink lately. Following (also mentioned in documentation) helped:

fink selfupdate -rsync


Return to Bugs