Orange Forum • View topic - installing under python 2.4.1

installing under python 2.4.1

A place to ask questions about methods in Orange and how they are used and other general support.

installing under python 2.4.1

Postby Guest » Sun May 29, 2005 16:47

I'd like to install orange on a windows machine containing python 2.4.1. The custom installer seems to work only with python 2.3 installed. Any way to install orange on winidows without needing to install python 2.3 as well?
Thanks.

Postby Guest » Sat Jun 11, 2005 16:04

I'd like to know this too.

Postby Guest » Thu Jul 21, 2005 13:01

Is it possible to recompile the current Orange source to use Python 2.4+? I would be more than happy to do it if someone could give me a sketch of the steps involved.

Me too

Postby Guest » Fri Aug 26, 2005 1:39

Anyone know how to get it to work wiht 2.41?

Do you think we can figure it out ourselves, reply if you think we can then we can try to recompile.

Postby Janez » Fri Sep 02, 2005 18:47

Sorry to keep you wating, guys :)

For a temporary solution, download the following binaries that are linked against Python 2.4: http://www.ailab.si/orange/download/orange_win_py24.zip. Also download the source distribution (any should do), unzip it into c:\Python24\lib\site-packages. Check that, for instance, orngTree.py is in c:\Python24\lib\site-packages\orange. Put the binaries into that same directory. Add the directory to Python library path (the simplest way is to add c:\python24\lib\site-packages\orange to the environment variable PYTHONPATH).

If you already have Orange for Python 2.3 installed, you can copy it from there to the equivalent Python 2.4's directory and unzip the binaries from the above archive over the old ones. And you'll have to fix the path.

After you do any of the above, run Python and try to import orange. If it doesn't find it, check the path (import sys; print sys.path)

Why all that hassle, why don't we fully support Python 2.4? The reason is that Orange Canvas uses some libraries that still haven't been ported to 2.4, so we cannot use that part or Orange with 2.4.

The above patch will only let you run scripts, but not the graphical stuff. Scripts should work OK - please tell me if they don't.

Regarding porting Orange to 2.4 yourselves: I wrote some instructions for compiling Orange long ago, but I have to update them, there are some missing steps. But you don't need it for now, anyway.

next version

Postby Guest » Thu Jan 19, 2006 23:13

Why all that hassle, why don't we fully support Python 2.4? The reason is that Orange Canvas uses some libraries that still haven't been ported to 2.4, so we cannot use that part or Orange with 2.4.


Is this still true? Exactly what libraries have not been ported?

Python 2.5 is now in the works and this very fine product won't be so fine if it doesn't try to keep up with the Python released versions. At some point, 2.5 will be released and this will still be only fully available for 2.3.

Postby Janez » Thu Jan 19, 2006 23:27

We're waiting for Riverbank's port of PyQt. Judging by their changelog they are working intensively on it -- the release was planned for the end of the year, so we hope it would be out soon. Since the Qt they are about to support is the newly released QPL version 4.0, not the old non-commercial 2.3 any more, we'll surely jump for it as soon as something stable comes out.

Postby Guest » Sat Apr 08, 2006 4:01

what about separate the orange and canvas to two parts. so we can use the machine learing lib more smoothly(without gui ).

Python 2.5 is alpha is available

Postby thegoldbug » Sun Apr 09, 2006 21:17

what is still the holdup on getting a download version for 2.4.x?

Postby Janez » Tue May 30, 2006 12:03

We are working on that; here's a bit of explanation of the problems we have: FAQ.

Orange under Python 2.4

Postby Jonna » Tue May 30, 2006 15:00

You don't happen to have a distribution for linux, similar to the binaries for windows mentioned above, which run under Python 2.4 without the GUI stuff?

this would be greatly appreciated
jonna

Have installed but cannot import

Postby guest » Wed May 31, 2006 13:13

hello
I've installed the orange directory under site package as you suggested and I can't import the orange module. I've other package in the sale location that work fine.

Can you help me ?


Return to Questions & Support