Orange Forum • View topic - installing under ubuntu 11.04

installing under ubuntu 11.04

A place to ask questions about methods in Orange and how they are used and other general support.

installing under ubuntu 11.04

Postby cormac » Tue Sep 20, 2011 16:55

Hi there, I've just installed orange and orange canvas on my ubuntu box here. When i installed it I noticed i was missing the visualise widgets. Managed to solve it by running:
apt-get install python-qt4-gl

Still missing a few, it seems though, Below is from Output Window
There were problems importing the following widgets:
OWNxExplorerQt: 'module' object has no attribute 'PlotItem'
OWSphereviz3D: 'module' object has no attribute 'PlotItem'
OWParallelCoordinatesQt: 'module' object has no attribute 'PlotItem'
OWRadvizQt: 'module' object has no attribute 'PlotItem'
OWLinProj3D: 'module' object has no attribute 'PlotItem'
OWDiscretizeQt: 'module' object has no attribute 'PlotItem'
OWLinProjQt: 'module' object has no attribute 'PlotItem'
OWPolyvizQt: 'module' object has no attribute 'PlotItem'
OWDistributionsQt: 'module' object has no attribute 'PlotItem'
OWScatterPlotQt: 'module' object has no attribute 'PlotItem'
OWScatterPlot3D: 'module' object has no attribute 'PlotItem'
OWRScript: No module named rpy2.robjects
The following widgets could not be imported and will not be available: OWSphereviz3D, OWLinProj3D, OWParallelCoordinatesQt, OWScatterPlotQt, OWRadvizQt, OWNxExplorerQt, OWLinProjQt, OWDistributionsQt, OWScatterPlot3D, OWDiscretizeQt, OWPolyvizQt.
The following prototype widgets could not be imported and will not be available: OWRScript.

Re: installing under ubuntu 11.04

Postby cormac » Tue Sep 20, 2011 17:19

My GUI crashed with a segmentation fault when I tried to launch any of the visualisations.
I uninstalled and reinstalled orange and this seems to have fixed it.
I also installed the python-rpy2 library to get rid of the OWRScript Error
I still see the PlotItem errors, but the visualisations seem to be working nonetheless.
Looking forward to having a good play with the system now!

Re: installing under ubuntu 11.04

Postby matija » Fri Oct 07, 2011 21:04

Hi,

just stumbled upon 'module' object has no attribute 'PlotItem' myself. This does not affect the widgets in Visualize tab. You can solve it by installing the python-qt4-gl package (so run
Code: Select all
sudo apt-get install python-qt4-gl
in the terminal).

With this, you gain the widgets that have not been visible to you because of this error, namely the ones in "Visualize Qt" tab. Those are the new visualization widgets that currently "live" alongside the old ones ("Visualize" tab), which remain the preferred ones for real work for the moment - the Qt widgets are still experimental due to lack of testing and polish. They should, however, be faster and more aesthetically pleasing than old ones, so go ahead and use them if you don't mind possible occasional crashes. :)

Regards,
Matija

Re: installing under ubuntu 11.04

Postby ubershmekel » Sun Jun 30, 2013 9:12

The new fix for this problem is

Code: Select all
sudo apt-get install python-qwt5-qt4


If anybody still hits this roadblock in 2013 (Ubuntu 12.10 build and setup from hg).


Return to Questions & Support



cron