Orange Forum • View topic - not found not found

A place to ask questions about methods in Orange and how they are used and other general support. not found

Postby vtn » Mon Jan 23, 2012 11:25

I tried to execute the code:

import sys
from PyQt4.QtGui import QApplication

appl = QApplication(sys.argv)

import OWNetExplorer

net ='')
net.items ='')

ow = OWNetExplorer.OWNetExplorer()

and get the following error:

Traceback (most recent call last):
File "/Workspaces/Python/PythonTests/src/", line 2, in <module>
from PyQt4.QtGui import QApplication
ImportError: dlopen(/Applications/, 2): Library not loaded: @executable_path/../Resources/Qt4/lib/QtGui.framework/Versions/4/QtGui
Referenced from: /Applications/
Reason: image not found

I am using a python executable found in the Orange distribution (the only way I found I could access orange through script):


Any idea to what I should change @executable_path/../Resources/Qt4/lib/QtGui.framework/Versions/4/QtGui for it to work? Thanks

Re: not found

Postby Ales » Mon Jan 23, 2012 13:27

Try running python included in the bundle with the '/Applications/' script

Re: not found

Postby vtn » Mon Jan 23, 2012 16:46

Thanks, it works awesomely. I feel silly not to have tried that before!

Return to Questions & Support