Orange Forum • View topic - Installing snapshots on Linux

Installing snapshots on Linux

A place to ask questions about methods in Orange and how they are used and other general support.

Installing snapshots on Linux

Postby Guest » Sun Mar 13, 2005 14:56

I updated my CVS working directory to the current and tried to compile it. Well, make worked. Great!!

make install did not, on the other hand. You can find the results of my make install here:

A quick grep reveals that there's an IndentationError in There are a whole host of errors near the end, Permission denied stuff. It looks as if sh was trying to run .pyc files.

I'm no Makefile guru, so I can't put my finger on the problem. But this is the same install problem I've had for a while. Any ideas?

By the way, I'm running this on Debian GNU/Linux.

Postby Repton » Mon Mar 14, 2005 0:58

Ditto on the installation problems.

The indent error appears to just be a missing ' ': In the named file, a class has two function definitions. One starts with " def" (3 spaces); the other starts with " def" (4 spaces).

I also notice lines like:

/bin/sh: line 1: /OrangeWidgets: No such file or directory

It looks like it's not picking up the DESTDIR variable in makefile.defs. Since there certainly should be no /OrangeWidgets directory :-)


Postby tomaz » Thu Oct 27, 2005 11:07

For Linux installation please see download page.

Return to Questions & Support