Orange Forum • View topic - Qt3 or Qt4 in svn ver1.0 code?

Qt3 or Qt4 in svn ver1.0 code?

A place to ask questions about methods in Orange and how they are used and other general support.

Qt3 or Qt4 in svn ver1.0 code?

Postby JFMuggs » Wed Jul 16, 2008 18:49

According to the instructions for installing orange from source for linux, Qt4 and PyQt 4 are needed to run the orange canvas. After following all the instructions, I can import orange and orngStat and such from the python command line, but when I attempt to use the canvas, I discovered that the modules for it all have "from qt import *" in the source, which is almost certainly a reference to PyQt3. I can work around this by importing the Qt3 dev tree from the ubuntu repositories, and then everything works, but this is a little confusing. Everything I have seen about the svn tree for orange (including this documentation) says that Qt4 is required.

Can anyone please clarify?

Thanks

Postby Gregor Leban » Thu Jul 17, 2008 11:25

Hi,

Orange 1.0 uses the older versions of qt (2.3 on windows and I guess 3.something on linux) which is why you have the "from qt import *".

If you download the snapshot version of orange, it requires qt 4. This version, which is now trunk on our svn, is still a work in progress, so you can expect to find some bugs (but does look much nicer).

hope this clarifies things a bit.

Gregor


Return to Questions & Support



cron