Orange Forum • View topic - Installing Orange on Ubuntu v7.04?

Installing Orange on Ubuntu v7.04?

A place to ask questions about methods in Orange and how they are used and other general support.

Installing Orange on Ubuntu v7.04?

Postby colinmac » Mon Jun 04, 2007 13:13

Hello folks,

After failing to get Orange fully working on Fedora Core 5, I'm now going to try my luck with Ubuntu v7.04.
Before I start, it seems sensible to ask if anyone else has already tried this. If so, I would be really interested in learning what version of Orange, python, qt, qwt, PyQt, PyQwt and numpy you have used.



Postby Guest » Mon Jun 04, 2007 14:48

It seems to be working on debian with the following:
Package: python-qwt4
Architecture: amd64
Source: pyqwt
Version: 4.2.2-1

Package: python-qt-dev
Architecture: all
Source: python-qt3
Version: 3.17.2-1

Package: sip4
Architecture: amd64
Source: sip4-qt3
Version: 4.6-1

Package: python-sip4
Architecture: amd64
Source: sip4-qt3
Version: 4.6-1

Package: python-sip4-dev
Architecture: all
Source: sip4-qt3
Version: 4.6-1

Postby colinmac » Tue Jun 05, 2007 13:42

Thank for the prompt message above.

I have orange working; but I now encounter an OverflowError whilst loading widgets . Does anyone have any suggestion as-to-how-to solve this?



Code: Select all
 File "/usr/lib/python2.5/site-packages/orange/OrangeWidgets/Visualize/", line 134, in __init__
  File "/usr/lib/python2.5/site-packages/orange/OrangeWidgets/Visualize/", line 142, in activateLoadedSettings
    dlg = self.createColorDialog()
  File "/usr/lib/python2.5/site-packages/orange/OrangeWidgets/Visualize/", line 369, in createColorDialog
    c.setColorSchemas(self.colorSettings, self.selectedSchemaIndex)
  File "/usr/lib/python2.5/site-packages/orange/OrangeWidgets/", line 468, in setColorSchemas
  File "/usr/lib/python2.5/site-packages/orange/OrangeWidgets/", line 519, in paletteSelected
  File "/usr/lib/python2.5/site-packages/orange/OrangeWidgets/", line 480, in setCurrentState
  File "/usr/lib/python2.5/site-packages/orange/OrangeWidgets/", line 327, in setPalette1
   image = QImage(bmp, dx, dy, 8, signedPalette(palette), 256, QImage.LittleEndian) # palette should be 32 bit, what is not so on some platforms (Mac) so we force it
OverflowError: long int too large to convert to int

Installing on Ubuntu Feisty

Postby psederberg » Fri Sep 07, 2007 17:13

After installing the dependencies above, I, too, am having issues compiling from source on Ubuntu Feisty Faun with the sources from cvs (orange-source-snap-2007-09-07.tgz). Here's the error I am receiving:

% python compile
Sipconfig not found, Qt version could not be found!
PyQwt not installed!
You can get it at:
Can not determine GCC version!
Orange specific data installation
running compile
Default compiler options are taken...
dictproxy.cpp: In function ‘PyObject* PyOrange_DictProxy_update(TPyOrange_DictProxy*, PyObject*)’:
dictproxy.cpp:195: error: cannot convert ‘int*’ to ‘Py_ssize_t*’ for argument ‘2’ to ‘int Py
Dict_Next(PyObject*, Py_ssize_t*, PyObject**, PyObject**)’
dictproxy.cpp: In function ‘PyObject* PyOrange_DictProxyIter_iternext(TPyOrange_DictyProxyIter*)’:
dictproxy.cpp:579: error: cannot convert ‘int*’ to ‘Py_ssize_t*’ for argument ‘2’ to ‘int Py
Dict_Next(PyObject*, Py_ssize_t*, PyObject**, PyObject**)’
make[1]: *** [obj/dictproxy.o] Error 1
make: *** [all] Error 1
Compiling... this might take a while, logging into compiling.log... Compiling Orange failed... exiting!

A couple of comments on the above:

1) sipconfig is installed, but it does not have a qt_version attribute.

2) PyQwt is also installed, but does not seem to be found, though I don't think that is the issue giving rise to the above problem.

Thanks for any suggestions,

Ubuntu 64-bit

Postby psederberg » Fri Sep 07, 2007 20:28

Hi Everyone:

In response to my own post, I found that my problems were due to the fact that I'm running 64-bit linux and Orange does not currently support it.

I did get it compile by following the suggestion from another post of casting the ints to the Py_ssize_t, but this is obviously not a longterm solution.

I hereby put in another vote for migrating the source towards 64-bit. It is the wave of the future :)


Postby Janez » Fri Sep 07, 2007 20:43

It works now? Or does it only compile?


Return to Questions & Support