Orange Forum • View topic - Installer for Python 2.6

Installer for Python 2.6

Discussions about new ideas and features you would like to see in Orange.
(Archived/read-only, please use our ticketing system for your wishes and their discussion.)
Forum rules
(Archived/read-only, please use our ticketing system for your wishes and their discussion.)

Installer for Python 2.6

Postby michaelhecht » Thu Feb 12, 2009 21:22

Would it be possible to prepare Orange also for Python 2.6 since I've installed this version and dont want to mix it with Python 2.5?

Postby Janez » Fri Feb 13, 2009 5:48

Python requires numpy, which has not been ported to 2.6 yet, afaik. I read that for now it only works for Linux - I've no idea why is that. Otherwise, I think we can go to 2.6 as soon as we have numpy.

This is what I found about numpy: "The current release, 1.2.1, is compatible with Python 2.4 and 2.5. On linux, NumPy supports Python 2.6, but windows support for Python 2.6 is behind schedule, having originally been planned for the third week of December 2008. Support for Python 3 is planned, but not yet scheduled."

Numpy 1.3.0 has been released

Postby nam » Tue Apr 07, 2009 13:09

Numpy 1.3.0 has been released on 2009-04-05 (including the build for windows).

Postby Janez » Tue Apr 07, 2009 20:39

Finally!

Great, thanks.

Postby Janez » Sat Apr 25, 2009 22:41

Orange should work in Python 2.6 now. There was a minor (undocumented!) change in Python's API, which required a fix in the C++ part of Orange, but otherwise it seems to work. I only tried it on Windows, I've put a few widgets on the canvas, but I haven't tried any regression tests yet. Besides, I couldn't try any visualization widgets - does anybody know of a PyQwt binary download for Windows for Python 2.6?

The version which runs on 2.6 is only available on the SVN. Installer for Windows will be ready soon.

I haven't tried it on Linux, since I don't want to mess with Python 2.6 on my Linux box. Can somebody try building it, so we know it works alright?

Thanks,
Janez

Installer for Python 2.6

Postby piecurus » Mon May 11, 2009 12:23

hi all,
I'm trying to install Orange with python 2.6 and ubuntu 9.04. I already installed Orange in ubuntu 8.04 without problems.
When I run
"sudo apt-get install python-qt3 python-qwt4 python-pygraphviz"
i get the following error
python-qwt4: Depends: python (< 2.6).
So, I understand that there is a problem installing pyqwt4.
How can I install Orange without the visual programming environment?
Thankyou very much!

Installer for Python 2.6

Postby piecurus » Mon May 11, 2009 12:27

looking at the pyqwt website, I see that pyqwt is only available for Python 2.5!

Postby aonlazio » Sun May 17, 2009 14:07

There is still be MySQLdb that have not yet supported python 2.5 . I am concerned that it might generate errors since I heavily use MySQL as the database back end. Could you check this issue also?
Thanks

it works in ubuntu 9.04

Postby keshav » Tue Jun 23, 2009 15:34

you have to first install python 2.5 in ubuntu, and then follow the installation instructions on 8.04. now run python2.5

"import orange" and "import orngStat" give no errors

neither does "python2.5 /usr/lib/python2.5/site-packages/orange/OrangeCanvas/orngCanvas.pyw"

i didn't try any mathematical functions with orange, but at least it doesnt give errors there


Return to Wish List



cron