Orange Forum • View topic - Segmentation fault - orange-svn package

Segmentation fault - orange-svn package

Report bugs (or imagined bugs).
(Archived/read-only, please use our ticketing system for reporting bugs and their discussion.)
Forum rules
Archived/read-only, please use our ticketing system for reporting bugs and their discussion.

Segmentation fault - orange-svn package

Postby toma » Thu Oct 07, 2010 21:13

Hi!

I get a segmentation fault when I try to run orange gui installed trough your deb repository using the orange-svn package. The segmentation fault occurs shorty after the initial loader popup is displayed.

Here is some additional information about my system:

Code: Select all
tomaz@homebox:~$ cat /etc/lsb-release
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=9.10
DISTRIB_CODENAME=karmic
DISTRIB_DESCRIPTION="Ubuntu 9.10"

tomaz@homebox:~$ uname -a
Linux tomaz-laptop 2.6.31-14-generic #48-Ubuntu SMP Fri Oct 16 14:04:26 UTC 2009 i686 GNU/Linux

tomaz@homebox:~$ python -V
Python 2.6.4

Postby Ales » Mon Oct 11, 2010 10:38

Can you also post which version of Qt, PyQt and PyQwt you have installed?

Postby toma » Mon Oct 11, 2010 12:10

Vse nateto je intalirano z default ubuntu repozitorijev. Upam da zadostuje, to kar ven pljune dpkg manager

Code: Select all
$ dpkg -s python-qwt5-qt4
Package: python-qwt5-qt4
Status: install ok installed
Priority: optional
Section: python
Installed-Size: 3404
Maintainer: Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Architecture: i386
Source: pyqwt5
Version: 5.1.1~cvs20090626+dfsg-1
Depends: libc6 (>= 2.3.4), libgcc1 (>= 1:4.1.1), libqt4-svg (>= 4.5.1), libqtcore4 (>= 4.5.1), libqtgui4 (>= 4.5.1), libqwt5-qt4, libstdc++6 (>= 4.1.1), python (<< 2.7), python (>= 2.5), python-support (>= 0.90.0), python-qt4 (>= 4.5.1), python-numpy
Recommends: libqwt5-qt4-dev
Description: Python version of the Qwt5 technical widget library
 PyQwt is a set of Python bindings for the Qwt C++ class library which extends
 the Qt framework with widgets for scientific and engineering applications.
 It provides a widget to plot 2-dimensional data and various widgets to
 display and control bounded or unbounded floating point values.
 .
 This version is compiled against Qt, version 4.
Original-Maintainer: Gudjon I. Gudjonsson <gudjon@gudjon.org>
Homepage: http://pyqwt.sourceforge.net/


Code: Select all
$ dpkg -s python-qt4
Package: python-qt4
Status: install ok installed
Priority: optional
Section: python
Installed-Size: 20240
Maintainer: Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Architecture: i386
Version: 4.6-1
Replaces: python-qt4-common, python-qt4-dev (<< 4.4.4-3~)
Provides: python2.5-qt4, python2.6-qt4
Depends: libc6 (>= 2.3.6-6~), libgcc1 (>= 1:4.1.1), libpython2.6 (>= 2.6), libqt4-assistant (>= 4.5.1), libqt4-designer (>= 4.5.1), libqt4-help (>= 4.5.1), libqt4-network (>= 4.5.1), libqt4-script (>= 4.5.1), libqt4-scripttools (>= 4.5.1), libqt4-svg (>= 4.5.1), libqt4-test (>= 4.5.1), libqt4-webkit (>= 4.5.1), libqt4-xml (>= 4.5.1), libqt4-xmlpatterns (>= 4.5.1), libqtcore4 (>= 4.5.1), libqtgui4 (>= 4.5.1), libstdc++6 (>= 4.1.1), python (<< 2.7), python (>= 2.5), python-support (>= 0.90.0), python-sip4 (>= 4.9), python-sip4 (<< 4.10)
Suggests: python-qt4-dbg
Conflicts: python-qt4-common
Description: Python bindings for Qt4
 PyQt4 exposes the Qt4 API to Python. The following modules are supported:
  * QtCore
  * QtGui
  * QtNetwork
  * QtXml
  * QtScript
  * QtSvg
  * QtTest
  * QtAssistant
  * QtWebKit
  * QtOpenGL (in python-qt4-gl)
  * QtSql (in python-qt4-sql)
  * phonon (in python-qt4-phonon)
Original-Maintainer: Debian Python Modules Team <python-modules-team@lists.alioth.debian.org>
Homepage: http://www.riverbankcomputing.co.uk/software/pyqt/


Code: Select all
$ dpkg -s libqtcore4
Package: libqtcore4
Status: install ok installed
Priority: optional
Section: libs
Installed-Size: 5320
Maintainer: Kubuntu Developers <kubuntu-devel@lists.ubuntu.com>
Architecture: i386
Source: qt4-x11
Version: 4.5.3really4.5.2-0ubuntu1
Replaces: libqt4-core (<< 4.4.0~beta1-1), libqt4-gui (<< 4.4.0~beta1-1)
Depends: libc6 (>= 2.4), libgcc1 (>= 1:4.1.1), libglib2.0-0 (>= 2.12.0), libstdc++6 (>= 4.1.1), zlib1g (>= 1:1.1.4)
Description: Qt 4 core module
 Qt is a cross-platform C++ application framework. Qt's primary feature
 is its rich set of widgets that provide standard GUI functionality.
 .
 The QtCore module contains core non-GUI functionality.
Homepage: http://www.qtsoftware.com
Original-Maintainer: Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>


ps: stvar sem zbuildal iz izvorne kode in dela brez problemov - tako scripting kot gui


Return to Bugs



cron