Orange Forum • View topic - Build Problems under Fedora Core 3

Build Problems under Fedora Core 3

A place to ask questions about methods in Orange and how they are used and other general support.

Build Problems under Fedora Core 3

Postby alexander.fairley » Tue May 31, 2005 11:57

:roll:
When I attempt to run the makefile, I'm running into a problem with the file orange/assoc.cpp. On line 36 there is a macro expansion for

DEFINE_TOrangeVector_classDescription(PAssociationRule, "TAssociationRules")

Apparently, gcc isn't happy with this macro as the following error message indicates:

>g++ -fPIC -w -DLINUX -O3 -DNO_NUMERIC -DNO_GSL -c orange/assoc.cpp -o >obj/assoc.o
>orange/assoc.cpp:36: error: too few template-parameter-lists
>orange/assoc.cpp:36: error: expected `,' or `;' before '=' token
>make: *** [obj/assoc.o] Error 1

I poked around in the source with grep, and found the definition of this macro, and it looks as though it's being called properly, so I would assume that the problem is in what the macro expands into, but I haven't looked into it with any depth. Anyone have a fix for this?

Alex

Postby jurem » Wed Jun 01, 2005 8:33

Hi,
that is strange indeed. I can compile it on Fedora Core 3 without any problems.

Can you please provide next information:

- which version of gcc/g++ are you using? (gcc --version)
- which version of python do you have?
- which source are you trying to build? (CVS checkout, snapshot from web..., from which date is it approximately?)

Regards, Jure

Postby alexander.fairley » Sun Jun 05, 2005 2:48

:D Sure, sorry, should have posted that the first time:

gcc =
Reading specs from /usr/lib/gcc/i386-redhat-linux/3.4.2/specs
Configured with: ../configure --prefix=/usr --mandir=/usr/share/man --infodir=/usr/share/info --enable-shared --enable-threads=posix --disable-checking --with-system-zlib --enable-__cxa_atexit --disable-libunwind-exceptions --enable-java-awt=gtk --host=i386-redhat-linux
Thread model: posix
gcc version 3.4.2 20041017 (Red Hat 3.4.2-6.fc3)

python=
Python 2.3.4

orange=
http://www.ailab.si/orange/download/orange-source-0.9.5.zip

It's really odd, because I looked at the source, and it looks like it ought to compile. I'm going to try downloading it fresh, just for the heck of it

Postby alexander.fairley » Mon Jun 06, 2005 13:35

:( Redownloading the source didn't solve anything...

Postby jgilbert » Wed Jun 08, 2005 2:07

You need to use gcc 3.3 for the stable version of Orange. Change all references in the Makefile to gcc with gcc33. Replace g++ with g++33. That should work.

You should be able, however, to build a CVS version. Just don't forget to checkout install-scripts/linux/setup.py.


Return to Questions & Support