Orange Forum • View topic - Crash on (K)Ubuntu 10.10 with Visu

Crash on (K)Ubuntu 10.10 with Visu

Report bugs (or imagined bugs).
(Archived/read-only, please use our ticketing system for reporting bugs and their discussion.)
Forum rules
Archived/read-only, please use our ticketing system for reporting bugs and their discussion.

Crash on (K)Ubuntu 10.10 with Visu

Postby russose » Mon Feb 14, 2011 7:22

Hello,

first, let me thank you for your wodnerfull program, it present a really interesting approach for data exploration.

After some difficulties to install orange on Kubuntu 10.10 (the package in the repository doesn't work...), I finally succeed in following this apporach:
1) download your source (orange-source-snapshot-2011-01-16)
2) compile with "python setup.py install --user"

But now, Orange crash seriously everytime I connect a file widget (for example) and lot of the Visu widget (like scatter plot, distribution) with the following message:

python: /build/buildd/sip4-qt3-4.10.5/siplib/siplib.c :2600 : sip_api_parse_result: L'assertion « assign_helper != ((void *)0) » a échoué.

Do you have any idea how can I solve this serious issues that make orange not usable for me?

Thanks for your help,

Salvatore

Re: Crash on (K)Ubuntu 10.10 with Visu

Postby Ales » Mon Feb 14, 2011 14:22

Do other widgets work. (i.e. Info, Data Table, NaiveBayes, Attribute Statistics)? If so then the problem would be in a broken PyQwt installation (Most visualization widgets depend on it). Did you build it yourself? For Ubuntu 10.10 there is a package for it in the official repos. Try reinstalling it.

Re: Crash on (K)Ubuntu 10.10 with Visu

Postby russose » Mon Feb 14, 2011 23:09

Hi Ales,

I installed in Kubuntu the PyQwt package (both qt3 and qt4):
sudo apt-get install python-qwt5-qt3 python-qwt5-qt4

I didn't compile any package (exept orange!) by myself on my machine.

I also installed many sip* related packages... but nothing helps, I still have these crash with scatterplot. For Attribute statistics, DataTable, I didn't experience this crash...

I tried to install orange without the --user, but still didn't work.

I uninstall everythink and used your debian repository, had to follow some hints from the forum to make it work... but then, I couldn't add any file, like explain in this post:
viewtopic.php?f=3&t=1071

Do you have any other way to make orange work? maybe it is a Pyqwt bug in ubuntu but I didn't found anything on the web regarding to such a bug.

thanks for your help,

Salvatore

Re: Crash on (K)Ubuntu 10.10 with Visu

Postby Ales » Tue Feb 15, 2011 11:02

I installed in Kubuntu the PyQwt package (both qt3 and qt4):
sudo apt-get install python-qwt5-qt3 python-qwt5-qt4

Maybe this is the problem. Orange uses Qt4 for GUI and therefore also uses pyqwt5 for qt4. Also in your previous posted the error
python: /build/buildd/sip4-qt3-4.10.5/siplib/siplib.c :2600 : sip_api_parse_result: L'assertion « assign_helper != ((void *)0) » a échoué.

Can you try uninstalling both packages, then installing just python-qwt5-qt4.

Re: Crash on (K)Ubuntu 10.10 with Visu

Postby russose » Tue Feb 15, 2011 15:04

Hello Ales,

I installed both in a desparate way since I had no other solution but I can guarantee that I only installed the version for qt4 and it was not working. After only I added the qt3 version hoping that it would work but without success.

What I don't understand is that I don't find in my system any /build/buildd/sip4-qt3-4.10.5/siplib/siplib.c file or directory: is it in orange source code? maybe orange is looking something in the wrong place and I could solve the situation making a link? I have no ideas...

Thanks for your help,

Salvatore

Re: Crash on (K)Ubuntu 10.10 with Visu

Postby Ales » Tue Feb 15, 2011 18:36

No. Orange does not come with any sip bindings.
I also have not have not idea what the problem could be.


Return to Bugs