Orange Forum • View topic - Widgets in Orange Canvas not highlighted

Widgets in Orange Canvas not highlighted

A place to ask questions about methods in Orange and how they are used and other general support.

Widgets in Orange Canvas not highlighted

Postby rpandeybhu » Sat Feb 23, 2013 20:31

Hi
I have recently installed orange. After opening the Canvas, I see only data table widget highlighted. As a result I am not able to do any computation. Initially, two widgets were also available in visualize but now they also appear gray.

I have uninstalled orange and all associated packages and then re-installed it. But the problem remains.
Please help me in this regard. I have tried to search the option to load widgets but failed to locate.

The content of the output window displayed below

There were problems importing the following widgets:
OWC45Tree: c45 is not found
OWItemsetViz: No module named OWNetworkCanvas
OWRScript: No module named rpy2.robjects
OWLinProj3D: No module named OpenGL
OWNxExplorer3D: No module named OWNxExplorerQt
OWScatterPlot3D: No module named OpenGL
OWSphereviz3D: No module named OpenGL
The following widgets could not be imported and will not be available: OWSphereviz3D, OWScatterPlot3D, OWLinProj3D, OWC45Tree, OWNxExplorer3D.
The following prototype widgets could not be imported and will not be available: OWRScript, OWItemsetViz.


Regards

Re: Widgets in Orange Canvas not highlighted

Postby Ales » Mon Feb 25, 2013 13:19

rpandeybhu wrote:After opening the Canvas, I see only data table widget highlighted. As a result I am not able to do any computation. Initially, two widgets were also available in visualize but now they also appear gray.

Have you tried clicking the widget buttons?
Most of the widgets recently got new icons, which follow a more black and white style. This somewhat clashes with the default background they get.

Re: Widgets in Orange Canvas not highlighted

Postby justsomeguy » Mon Feb 25, 2013 18:45

i have the same issue. screenshot http://i.imgur.com/8YWvFlW.png

i have the most recent version installed, and at some point i did have the new icons.

now most of the icons are missing, and i haven't changed anything in the installation at all. only thing i've really done of consequence has been to reboot my pc since the last time the icons were displayed correctly.

i tried re-installing. no difference.

Re: Widgets in Orange Canvas not highlighted

Postby Ales » Mon Feb 25, 2013 19:51

Strange. It seems like it can't read SVG icons.
Can you still place a widget on the canvas and open it? If so can you open the 'Python Script' widget and paste and execute this script
Code: Select all
from PyQt4.QtGui import QImageReader, QApplication
print map(str, QImageReader.supportedImageFormats())

print map(str, QApplication.libraryPaths())
Can you paste the output

If you can't place the widget in the canvas then run this in the Python console
Code: Select all
from PyQt4.QtGui import QImageReader, QApplication
app = QApplication([])

print map(str, QImageReader.supportedImageFormats())

print map(str, QApplication.libraryPaths())

Re: Widgets in Orange Canvas not highlighted

Postby justsomeguy » Mon Feb 25, 2013 20:05

output when run from inside the Python Script widget:

['bmp', 'pbm', 'pgm', 'png', 'ppm', 'xbm', 'xpm']
['C:/Python27/Lib/site-packages/PySide/plugins', 'C:/Python27']

from that output i think i understand that the PySide installation (which i installed this morning out of curiousity based on a reddit thread) is probably interfering

Re: Widgets in Orange Canvas not highlighted

Postby justsomeguy » Mon Feb 25, 2013 21:19

alright, so i had to do an entirely new reinstall of python to get everything to work normally again.

THANKS PYSIDE :evil:

thanks Ales for helping me find out what went wrong.

Re: Widgets in Orange Canvas not highlighted

Postby rpandeybhu » Tue Feb 26, 2013 6:48

Thanks a lot Ales for responding to my query. As I am new, I'll try one by one all the suggestions that has appeared here.

However, in my case the icons of widget appear (in Gray) and I can put them on canvas. The problem is that I do not get any output. Only a blank output screen appears. Further, when I attach the data file to any widget an yellow triangle with question mark appear. But when I attach the file with data table widget (which is functional) and then I attach the data table to any widget the said problem goes away. But even in this case also the other widgets do not function (as indicated by blank output file).
Alels, I again thank you for all. I'll revert back with whatever result I get.

Re: Widgets in Orange Canvas not highlighted

Postby rpandeybhu » Tue Feb 26, 2013 6:52

Dear Ales
I tried to run the script in the Python widget and following output appeared in the console

(PythonConsole)
>>>
Running script:
Traceback (most recent call last):
File "<console>", line 1, in <module>
File "<string>", line 2
from PyQt4.QtGui import QImageReader, QApplication
^
IndentationError: unexpected indent
>>>

Re: Widgets in Orange Canvas not highlighted

Postby Ales » Tue Feb 26, 2013 14:00

rpandeybhu wrote:I tried to run the script in the Python widget and following output appeared in the console
Paste the script in the 'Python script' box and press 'Execute' button (the console in the widget does not properly paste multi line scripts).

Although if the icons are displayed this is a different problem and the output here will not tell much.

rpandeybhu wrote: Further, when I attach the data file to any widget an yellow triangle with question mark appear.
Hover the mouse over the triangle icon. A tooltip should appear with some kind of (hopefully) informative message.

Re: Widgets in Orange Canvas not highlighted

Postby rpandeybhu » Tue Feb 26, 2013 20:15

Dear Ales
Thanks for your prompt reply

I pasted the script in python script box as new script and the execute button gave the following output
Running script:
['bmp', 'gif', 'ico', 'jpeg', 'jpg', 'mng', 'pbm', 'pgm', 'png', 'ppm', 'svg', 'svgz', 'tif', 'tiff', 'xbm', 'xpm']
['C:/Python27/Lib/site-packages/PyQt4/plugins', 'C:/Python27']

But as a novice I could not comprehend what this output suggests.
Please help in shorting out my problem and resolving it.

I am pasting the link to image of my Orange Canvas with output file for your convenience to locate the problem

http://rpandeybhu.webs.com/orange_scren.jpg

Re: Widgets in Orange Canvas not highlighted

Postby rpandeybhu » Tue Feb 26, 2013 20:27

I have installed Python v 2.7

Further, the output file does not appear in the image linked in my earlier post. The content of the output file is pasted below

There were problems importing the following widgets:
OWC45Tree: c45 is not found
OWItemsetViz: No module named OWNetworkCanvas
OWRScript: No module named rpy2.robjects
OWLinProj3D: No module named OpenGL
OWNxExplorer3D: No module named OWNxExplorerQt
OWScatterPlot3D: No module named OpenGL
OWSphereviz3D: No module named OpenGL
The following widgets could not be imported and will not be available: OWSphereviz3D, OWScatterPlot3D, OWLinProj3D, OWC45Tree, OWNxExplorer3D.
The following prototype widgets could not be imported and will not be available: OWRScript, OWItemsetViz.

Re: Widgets in Orange Canvas not highlighted

Postby rpandeybhu » Fri Mar 01, 2013 21:58

Dear Ales
Hope you are still trying try to locate the problem. I am verymuch hopeful that with your invaluable suggestions and help I'll be able to explore the functionality to the Orange Canvas.

I am still trying on my own but failed. I installed it on Windows 8 and Vista but the same problem.

I also request other esteemed members to help me in this regard.

Re: Widgets in Orange Canvas not highlighted

Postby Ales » Mon Mar 04, 2013 10:08

The screen shot looks normal.
Like I said in the first reply, some of the icons simply have a gray scale theme.

Re: Widgets in Orange Canvas not highlighted

Postby rpandeybhu » Tue Mar 05, 2013 6:05

Dear Ales

Thanks a lot for all your help. I tried the 'visualize' icons with the data file and all of them are working. However, I am not able to perform ROC or other multivariate analysis. Hope, there must be some problem in organizing my data. Though, I used the select attribute and other required modules, I think that I am not giving the data to Orange in required format. I'll try to learn about them from the information available on web page.

Thanking you once again.


Return to Questions & Support



cron