Orange Forum • View topic - SIP API Problem

SIP API Problem

A place to ask questions about methods in Orange and how they are used and other general support.

SIP API Problem

Postby sebi06 » Thu Mar 21, 2013 17:12

Hi guys,

i just tried out using orange from a python script directly and git the following error:

...
File "C:\Python27\lib\site-packages\Orange\OrangeWidgets\plot\owcurve.py", line 138, in <module>
from Orange import orangeqt
RuntimeError: the sip module implements API v9.0 to v9.1 but the orangeqt module requires API v8.0


Does this mean I have to downgrade the SIP module. And if yes, how to do this?

Thanks for the help,

Sebi

Re: SIP API Problem

Postby Ales » Fri Mar 22, 2013 19:03

You would need to uninstall PyQt4 an install a compatible one (the one that is included with Orange installer). However this might break any other program using PyQt4 or sip.


Return to Questions & Support



cron