source: orange/setup-site.cfg @ 11670:d967a4ceb8b4

Revision 11670:d967a4ceb8b4, 2.1 KB checked in by Björn Esser <bjoern.esser@…>, 8 months ago (diff)

Updated the included LIBLINEAR to version 1.93.

RevLine 
[9067]1####################################
2# Orange build process configuration
3####################################
4#
5#  The Orange sources come bundled with some third party libraries
6# that are build and linked (statically) into Orange.
7# These are:
8#
9#  * BLAS (a subset)
[11670]10#  * LIBSVM (v3.17 - v3.* is required)
11#  * LIBLINEAR (v1.93 - >= 1.9 is preferred, <= 1.8 needs a special cflag)
[11669]12#  * LINPACK (can be substituted by libR)
[9067]13#  * QHull
14#
15#  You can customize the build process to instead link to the
16# corresponding external library by modifying this file before
17# running the setup.py script.
18#
19#  To indicate that you want to link to an external library simply
20# uncomment the 'library = name' line in the corresponding section.
21# The 'name' argument must name the library you want to link with.
22# This is usually already correct, but sometimes you would need to
23# change it, for instance use 'blas_mt' (usually) for a
24# multi-threaded blas (or 'goto_blas', 'atlas' etc.)
25#
26#  Currently you still have to set the search paths (for both
[10250]27# libraries and header files) using the CFLAGS, CPPFLAGS and
[9067]28# LDFLAGS env. variables for compiler and linker to find your
29# library (if not on the default search path). Support for
30# configuring them through this file is planned.
[10250]31#
32#  If building and installing with an automated package manager
33# (easy_install or pip) setup.py will also read '~/.orange-site.cfg'
34# file for configuration options.
[9067]35
[9043]36[GLOBALS]
37
38####################
39# BLAS configuration
40####################
41
[9067]42[blas] 
[9043]43#library = blas
44
45######################
46# LibSVM configuration
47######################
48
49[libsvm]
[9067]50#library = svm
[9043]51
52#########################
53# LIBLINEAR configuration
54#########################
[11670]55#
56# If you want to use LIBLINEAR <= 1.8 you will need to add a
57# special cflag "-DWITH_API_LIBLINEAR18" to your system's CFLAGS.
58# e.g. export CFLAGS="$CFLAGS -DWITH_API_LIBLINEAR18"
[9043]59
60[liblinear]
[9067]61#library = linear
[9043]62
[11669]63##############################
64# LINPACK / libR configuration
65##############################
66
67[R]
68#library = R
69
[9043]70#####################
71# QHull configuration
72#####################
73
74[qhull]
[9067]75#library = qhull
Note: See TracBrowser for help on using the repository browser.