Ticket #1006 (closed bug: fixed)

Opened 3 years ago

Last modified 3 years ago

plot tools (plot) doc does not compile

Reported by: miha Owned by: miha
Milestone: 2.6 Component: documentation
Severity: minor Keywords:
Cc: Noughmad, mitar Blocking:
Blocked By:

Description

Plot tools documentation, written by Miha Čančula (bottom of  http://orange.biolab.si/doc/orange25) does not compile on the server. See also  http://orange.biolab.si/doc/orange25/OrangeWidgets.plot.html.

Attachments

svn-hook-cron.log Download (51.4 KB) - added by mitar 3 years ago.

Change History

Changed 3 years ago by mitar

comment:1 Changed 3 years ago by mitar

  • Cc Noughmad added
  • Status changed from new to assigned
  • Owner changed from mitar to miha

I have attached compile log for documentation on the server. Suggestions?

comment:2 Changed 3 years ago by mitar

  • Milestone changed from future to current

comment:3 Changed 3 years ago by miha

Run import orangeqt on the server.

comment:4 Changed 3 years ago by Noughmad

Traceback (most recent call last):
430	  File "/usr/lib/pymodules/python2.6/sphinx/ext/autodoc.py", line 329, in import_object
431	    __import__(self.modname)
432	  File "/srv/orange-doc/orange/OrangeWidgets/plot/__init__.py", line 15, in <module>
433	    from owcurve import *
434	  File "/srv/orange-doc/orange/OrangeWidgets/plot/owcurve.py", line 136, in <module>
435	    from OWBaseWidget import *
436	  File "/srv/orange-doc/orange/OrangeWidgets/OWBaseWidget.py", line 26, in <module>
437	    from orngSignalManager import *
438	  File "/srv/orange-doc/orange/OrangeCanvas/orngSignalManager.py", line 675, in <module>
439	    globalSignalManager = SignalManager()
440	  File "/srv/orange-doc/orange/OrangeCanvas/orngSignalManager.py", line 133, in __init__
441	    self.log.addHandler(logging.handlers.RotatingFileHandler(self.logFileName, maxBytes=2**20, backupCount=2))
442	  File "/usr/lib/python2.6/logging/handlers.py", line 112, in __init__
443	    BaseRotatingHandler.__init__(self, filename, mode, encoding, delay)
444	  File "/usr/lib/python2.6/logging/handlers.py", line 64, in __init__
445	    logging.FileHandler.__init__(self, filename, mode, encoding, delay)
446	  File "/usr/lib/python2.6/logging/__init__.py", line 827, in __init__
447	    StreamHandler.__init__(self, self._open())
448	  File "/usr/lib/python2.6/logging/__init__.py", line 846, in _open
449	    stream = open(self.baseFilename, self.mode)
450	IOError: [Errno 2] No such file or directory: '/var/www/.orange/OrangeCanvasQt4/signalManager.log'

The problem is in orngSignalManager, which can't find the file signalManager.log.

Maybe the build process doesn't have permissions to write into that folder?

comment:5 Changed 3 years ago by miha

I have fixed orngSignalManager. Let's just wait for the server to compile again.

comment:6 Changed 3 years ago by mitar

  • Cc mitar added

comment:7 Changed 3 years ago by mitar

OrangeQT does not get compiled, it runs, but it does not do anything:

cd build; cmake -DCMAKE_BUILD_TYPE=Release -DORANGE_LIB_DIR=/srv/orange-doc/orange -DPYTHON_EXECUTABLE=/usr/bin/python -DCMAKE_USE_PYTHON_VERSION=2.6  ..
-- Found PyQt4 version: 4.7.3
-- Found SIP version: 4.10.2
-- Found Python executable: /usr/bin/python
-- Found Python version: 2.6.6
-- Found Python library: /usr/lib/libpython2.6.so
-- Numpy headers found
-- Configuring done
-- Generating done
-- Build files have been written to: /srv/orange-doc/orange/source/orangeqt/build
if ! make all -C build; then exit 1; fi;
make[2]: Entering directory `/srv/orange-doc/orange/source/orangeqt/build'
make[3]: Entering directory `/srv/orange-doc/orange/source/orangeqt/build'
make[4]: Entering directory `/srv/orange-doc/orange/source/orangeqt/build'
make[4]: Leaving directory `/srv/orange-doc/orange/source/orangeqt/build'
[100%] Built target python_module_orangeqt
make[3]: Leaving directory `/srv/orange-doc/orange/source/orangeqt/build'
make[2]: Leaving directory `/srv/orange-doc/orange/source/orangeqt/build'
make[1]: Leaving directory `/srv/orange-doc/orange/source/orangeqt'

comment:8 Changed 3 years ago by miha

  • Status changed from assigned to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.