Ticket #1019 (closed check: fixed)

Opened 3 years ago

Last modified 3 years ago

Regression test fails

Reported by: miha Owned by: miha
Milestone: Future Component: orng_modules
Severity: major Keywords:
Cc: Noughmad, lanz Blocking:
Blocked By:

Description

Please check and fix the logreg test. Something strange is happening here. Should "Wald Z" test work on this data or should we remove this from testing?

Test results:  http://orange.biolab.si/download/regressionLogs/winxp/regression_tests_orange_report.html

Change History

comment:1 Changed 3 years ago by lanz

  • Owner changed from lanz to miha
  • Status changed from new to assigned
  • Cc lanz added

The regression test fails because in the computation of WaldZ there is a division by standard error, which is 0 in all cases. Division by zero used to produce 'inf' while now it returns '1.$' (this actually depends on the computer - I still get 'inf').

But there should not be a division by zero anyway - first the computation of the standard error needs to be corrected. Then there shouldn't be any more problems with WaldZ as well.

comment:2 Changed 3 years ago by miha

  • Status changed from assigned to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.