Ticket #1234 (closed bug: worksforme)

Opened 19 months ago

Last modified 19 months ago

Installing Orange through pip fails

Reported by: mitar Owned by: anze
Milestone: 2.5 Component: other
Severity: major Keywords:
Cc: Blocking:
Blocked By:

Description (last modified by mitar) (diff)

pip install Orange fails with:

Installing collected packages: Orange, numpy
  Running setup.py install for Orange
    Error [Errno 2] No such file or directory: '/Users/mitar/.virtualenv/myflow/build/Orange' while executing command /Users/mitar/.virtualenv/myflow/bin/python -c "import setuptools;__file__='/Users/mitar/.virtualenv/myflow/build/Orange/setup.py';exec(compile(open(__file__).read().replace('\r\n', '\n'), __file__, 'exec'))" install --single-version-externally-managed --record /var/folders/j4/xvt9q_jx4l1b0wqmn9l6scl00000gn/T/pip-cjBKyW-record/install-record.txt --install-headers /Users/mitar/.virtualenv/myflow/bin/../include/site/python2.7
Exception:
Traceback (most recent call last):
  File "/Users/mitar/.virtualenv/myflow/lib/python2.7/site-packages/pip-1.1-py2.7.egg/pip/basecommand.py", line 104, in main
    status = self.run(options, args)
  File "/Users/mitar/.virtualenv/myflow/lib/python2.7/site-packages/pip-1.1-py2.7.egg/pip/commands/install.py", line 250, in run
    requirement_set.install(install_options, global_options)
  File "/Users/mitar/.virtualenv/myflow/lib/python2.7/site-packages/pip-1.1-py2.7.egg/pip/req.py", line 1133, in install
    requirement.install(install_options, global_options)
  File "/Users/mitar/.virtualenv/myflow/lib/python2.7/site-packages/pip-1.1-py2.7.egg/pip/req.py", line 577, in install
    cwd=self.source_dir, filter_stdout=self._filter_install, show_stdout=False)
  File "/Users/mitar/.virtualenv/myflow/lib/python2.7/site-packages/pip-1.1-py2.7.egg/pip/__init__.py", line 221, in call_subprocess
    cwd=cwd, env=env)
  File "/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/subprocess.py", line 672, in __init__
    errread, errwrite)
  File "/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/subprocess.py", line 1202, in _execute_child
    raise child_exception
OSError: [Errno 2] No such file or directory: '/Users/mitar/.virtualenv/myflow/build/Orange'

Of course there is no directory build there.

Change History

comment:1 Changed 19 months ago by mitar

  • Description modified (diff)

comment:2 Changed 19 months ago by mitar

  • Severity changed from minor to major

comment:3 Changed 19 months ago by mitar

  • Status changed from new to closed
  • Resolution set to fixed

Cannot reproduce this myself. ;-)

comment:4 Changed 19 months ago by mitar

  • Status changed from closed to reopened
  • Resolution fixed deleted

comment:5 Changed 19 months ago by mitar

  • Status changed from reopened to closed
  • Resolution set to worksforme
Note: See TracTickets for help on using tickets.