Ticket #1239 (closed bug: fixed)

Opened 23 months ago

Last modified 23 months ago

LibLinear weights

Reported by: lanz Owned by: ales
Milestone: Component: library
Severity: major Keywords:
Cc: Blocking:
Blocked By:

Description

Weights obtained from a LinearClassifier (from LinearSVMLearner or LibLinearLogRegLearner) sometimes predict class 0 and sometimes class 1.

Change History

comment:1 Changed 23 months ago by Ales Erjavec <ales.erjavec@…>

In [e9a6850a6818484cd60180ba02638e9b43ebbaff/orange]:

Fix the weight vector exposed to python if liblinear internally reorders the values of the binary class.

(references #1239)

comment:2 Changed 23 months ago by ales

Lan, can you check if the problem is still present after the last changeset. Also please run

python -m unittest Orange.testing.unit.tests.test_linear

comment:3 Changed 23 months ago by lanz

  • Status changed from new to closed
  • Resolution set to fixed

The unit tests succeed and my experiments also started working.

Thanks for the quick fix.

Note: See TracTickets for help on using tickets.