Ticket #1285 (assigned bug)

Opened 19 months ago

Last modified 19 months ago

Installer doeas not work - manual installation yields QT4 incompatibility

Reported by: lareooreal Owned by: ales
Milestone: Component: library
Severity: immediate Keywords: installation
Cc: Blocking:
Blocked By:

Description

The installationprocedure of Orange is ever since not working very well! Right now it requires manual installation of all components. Would you please mind to post a full list of requirements of _working_ software libraries of numpy,scypy etc.. Obviously the current QT4 version does not install and is not compatible. the plugins do not load all properly either.

Please TEST your software before relasing- otherwise it is a lot of wasted time to try to setup a running installation.

Greetings Lareo

Change History

comment:1 Changed 19 months ago by ales

  • Status changed from new to assigned
  • Owner set to ales

The installationprocedure of Orange is ever since not working very well!

True

Right now it requires manual installation of all components.

Can you provide more details (OS, Python version, ...). What exactly does not work (and how).

Would you please mind to post a full list of requirements of _working_ software libraries of numpy,scypy

It works with numpy >= 1.5, scipy >= 0.9, Qt4 >= 4.6, PyQt4 >= 4.8, PyQwt >= 5.2 Note that PyQt4 and PyQwt must be build with a compatible sip library.

comment:2 Changed 19 months ago by mitar

hdz replied on the e-mail:

To answer your question. Orange looses its functionality after a while, when frequently updating. The problem is, that after Orange was once installed a complete reinstall does not work anymore. i removed path information and Pyhton, cleaned the registry. The installer starts and seems to work but it is not registering the components correctly. This is the reason I needed the exact list of what component to install. Here I would recommend to put this information on the website again. It was once there anywhere. I started Orange by console to see what was missing and therefore I reinstalled everything, Numpy, Scypy etc. but i ended in a halt with QT versions. II got the message that it is not compatible and this was the halt.

Note: See TracTickets for help on using tickets.