Ticket #1315 (closed bug: fixed)

Opened 10 months ago

Last modified 7 months ago

Segfault running docs/reference/rst/code/instance_merge.py

Reported by: ales Owned by: ales
Milestone: Future Component: library
Severity: major Keywords:
Cc: Blocking:
Blocked By:

Description (last modified by ales) (diff)

The script segfaults in TExample::traverse on with visit_decref.

This happens after at python interpreter finalization.

Attachments

test_merge.py Download (444 bytes) - added by ales 7 months ago.
Minimal script to reproduce the error

Change History

comment:1 Changed 10 months ago by ales

  • Description modified (diff)

Changed 7 months ago by ales

Minimal script to reproduce the error

comment:2 Changed 7 months ago by ales

The TExample::traverse iterates pass the items values array because the classes_end is not initialized in the TExample merging constructor.

comment:3 Changed 7 months ago by Ales Erjavec <ales.erjavec@…>

  • Status changed from new to closed
  • Resolution set to fixed

In [6f5c66aed28e55a242affc87dbb5602533d45e8d/orange]:

Initialize the 'classes_end' member in TExample merging constructor.

(fixes #1315).

Note: See TracTickets for help on using tickets.