Ticket #1326 (closed bug: fixed)

Opened 12 months ago

Last modified 11 months ago

Crash on import

Reported by: bkaluza Owned by:
Milestone: Component: library
Severity: major Keywords:
Cc: Blocking:
Blocked By:

Description

After fresh install on Ubuntu using

$ virtualenv pyorange
$ source pyorange/bin/activate
(pyorange)$ pip install numpy
(pyorange)$ pip install orange

I get the following error

(pyorange):$ python
Python 2.7.3 (default, Apr 10 2013, 05:13:16) 
[GCC 4.7.2] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> import orange
/home/bostjan/pyorange/local/lib/python2.7/site-packages/Orange/__init__.py:111: UserWarning: Some features will be disabled due to failing modules
Importing 'classification.neural' failed: No module named scipy.sparse
  _import("classification.neural")
/home/bostjan/pyorange/local/lib/python2.7/site-packages/Orange/__init__.py:129: UserWarning: Importing 'regression.lasso' failed: No module named scipy.linalg
  _import("regression.lasso")

Change History

comment:1 Changed 11 months ago by ales

  • Status changed from new to closed
  • Resolution set to fixed

scipy was missing from the package dependencies list. You can run

pip install scipy

to install it (note it needs fortran compiler (sudo apt-get install gfortran)

Fixed in 16aa1cc62ffb

Note: See TracTickets for help on using tickets.