Ticket #706 (closed bug: fixed)

Opened 3 years ago

Last modified 3 years ago

[Debian] Python version linkage

Reported by: inequation Owned by: mitar
Milestone: 2.6 Component: library
Severity: major Keywords:
Cc: lg@… Blocking:
Blocked By:

Description

The orange-svn debian packages are linked against Python 2.5, whereas debian has been providing 2.6 for a while now. As a result, the package is not functional.

Change History

comment:1 Changed 3 years ago by mitar

  • Status changed from new to accepted
  • Owner changed from janez to mitar

comment:2 Changed 3 years ago by mitar

Packages have been updated to 2.6 (Debian squeeze). The only problem is that binary components are compiled against just this version, so if you want to use some other existing version of Python things will not work. But at least with default version will now work again.

comment:3 Changed 3 years ago by mitar

  • Status changed from accepted to closed
  • Resolution set to fixed

OK. With some hacking packages are now compiled both for 2.6 and 2.7 and it seems they work both on Debian stable and Ubuntu.

Note: See TracTickets for help on using tickets.