Ticket #799 (closed bug: fixed)

Opened 3 years ago

Last modified 3 years ago

Deleting widgets on Ubuntu 10.10

Reported by: ales Owned by: ales
Milestone: Future Component: canvas
Severity: major Keywords:
Cc: Blocking:
Blocked By:

Description

Deleting a widget using QGraphicsView from the canvas crashes orange (stack trace indicates it crashes in QGraphicsView::paintEvent). Investigate.

Change History

comment:1 Changed 3 years ago by ales

Seems to be related to the use of Drop Shadows in the canvas and is not limited to Linux, also reproducible on Mac. The crash ocures in:

QGraphicsSceneFindItemBspTreeVisitor::visit(QList<QGraphicsItem*>*)

comment:2 Changed 3 years ago by ales

In [11390]:

(The changeset message doesn't reference this ticket)

comment:3 Changed 3 years ago by ales

comment:4 Changed 3 years ago by ales

  • Status changed from new to closed
  • Resolution set to fixed

Implemented a workaround (as suggested in the link bugreport link i.e. prepare geometry change remove and child items before the item is deleted) in rev caf0633e9109.

Note: See TracTickets for help on using tickets.