Ticket #832 (closed bug: fixed)

Opened 3 years ago

Last modified 3 years ago

MeasureAttribute_relief raises na exception on regression datasets.

Reported by: ales Owned by: janez
Milestone: Future Component: other
Severity: minor Keywords:
Cc: Blocking:
Blocked By:

Description (last modified by ales) (diff)

when evaluating an attribute on a data-set with continuous class. Example code:

import Orange
data = Orange.data.Table("auto-mpg")
Orange.feature.scoring.Relief(data.domain[0], data)

raises

KernelException: 'orange.AttributedFloatList': vector subscript out of range

The problem seems to be in measures.cpp:1206. The ExamplesDistance_relief::operator()(int&, TValue&, TValue&) gets called for the class, but the normalizations/averages for the class variable are no longer computed since r8714.

Change History

comment:1 Changed 3 years ago by ales

  • Status changed from new to assigned
  • Owner set to janez
  • Description modified (diff)

comment:2 Changed 3 years ago by ales

  • Status changed from assigned to closed
  • Resolution set to fixed

In [11472]:

(The changeset message doesn't reference this ticket)

Note: See TracTickets for help on using tickets.