Ticket #944 (closed bug: fixed)

Opened 3 years ago

Last modified 3 years ago

Orange does not start on Ubuntu

Reported by: mitar Owned by: ales
Milestone: 2.6 Component: canvas
Severity: major Keywords:
Cc: Blocking:
Blocked By:

Description (last modified by mitar) (diff)

Orange canvas fails with:

Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/orange/OrangeCanvas/orngCanvas.pyw", line 1168, in <module>
    sys.exit(main())
  File "/usr/lib/python2.7/dist-packages/orange/OrangeCanvas/orngCanvas.pyw", line 1158, in main
    dlg = OrangeCanvasDlg(app)
  File "/usr/lib/python2.7/dist-packages/orange/OrangeCanvas/orngCanvas.pyw", line 218, in __init__
    orngTabs.constructCategoriesPopup(self)
  File "/usr/lib/python2.7/dist-packages/orange/OrangeCanvas/orngTabs.py", line 669, in constructCategoriesPopup
    categoriesPopup = CanvasPopup(canvasDlg)
  File "/usr/lib/python2.7/dist-packages/orange/OrangeCanvas/orngTabs.py", line 578, in __init__
    self.suggestDict = dict([(widget.name, widget) for widget in reduce(lambda x,y: x+y, [cat.values() for cat in cats.values()])])
TypeError: reduce() of empty sequence with no initial value

Ubuntu 11.04, i386. With both 2.6 and 2.7. Clean installation from package, r12035.

Change History

comment:1 Changed 3 years ago by mitar

  • Description modified (diff)

comment:2 Changed 3 years ago by ales

In [12043]:

References #944.
Fixed an error when a widget category has no widgets.

comment:3 Changed 3 years ago by ales

I could not duplicate the exact error. However I think the r12043 should fix it. Mitar can you check if it works now.

comment:4 Changed 3 years ago by mitar

  • Status changed from new to closed
  • Resolution set to fixed

Works now. The main problem was that absolutely no widget was found (because we had check for symlinks, [12046]), so the code above failed.

Note: See TracTickets for help on using tickets.