Version 26 (modified by miha, 3 years ago) (diff)


Basically, the goals are the beauty of the interface and backwards compatibility. Let's be a bit more specific:

  • New structure. Adhere to the pythonic naming; in particular, replace camelCase with underscore_separated methods.
  • Backwards compatibility needs to be retained at any cost (old scripts and widgets have to work in their unmodified form). If it would not take too much work empty the old module. If you decide that this would introduce too many bugs leave the old module as it is.
  • Everything that was documented prior to 2.5 has to be documented now.


Described on the rst documentation page.

Compiled documentation can be found here (still work in progress).

Compiled documentation on using OWPlot in widget development can be found  here.


 EtherPad page

CamelCase to underscore_separated

Names of methods, functions, (object) attributes and keyword attributes of functions should all be underscore_separated. Abbreviations should also be in lower case. For example, we should rename AUCWilcoxon to auc_wilcoxon (and not AUC_wilcoxon).

For now, all C++ code is accessible both with CamelCase and underscore separated (detailed description). Python code should be converted with name deprecation decorators (see the page for an example).

Refactoring tool

Do forget to update the refactoring rules.

Things to check/fix later

Aliases in C code to make

  • Floating-point numbers and functions are formatted in a weird fashion when enumerating default function parameter values.
  • Base classes are determined inappropriately for our needs: for example, orange.RuleLearner is written (and linked) instead of its alias Orange.classification.rules.RuleLearner (or at least Orange.core.RuleLearner).